Emulators on Linux

From Emulation General Wiki
Jump to navigation Jump to search

Distro-agnostic packages are application portability solutions in Linux.

There are thousands of different distributions of Linux, and many of these use different package systems to manage application installation. Some popular ones are .deb format used by Debian, Ubuntu and its variants, and there is also RPM format used by Fedora, RedHat, and many others. Packages of the game console and computer emulators exist for popular Linux distros, usually available from the official software repositories of the distribution, but they are usually very old compared to the upstream versions. In addition, these packages are typically made only for one single version of the distribution, and due to dependency problems, these can not be used in other distros. There are at least three new package formats that are aiming to bring application portability to the Linux ecosystem. Packages using these formats are quite huge in file size due to bundling all dependencies in it, but they can run in any popular Linux distros.

Flatpak[edit]

Flatpak (formerly xdg-app) is a distro-agnostic application framework. It is a decentralized system and has no central package repository. Instead, the user must manually add the repository's URL to the system before packages can be installed, like in Ubuntu's PPA.

Flathub, probably the biggest Flatpak repository, has several emulators.

To install emulators from Flathub, add the location of Flathub repository to your system:

$ flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo

List of available application package names can be obtained by the following command:

$ flatpak remote-ls flathub

Use the following command to install the emulator from Flathub:

$ flatpak install flathub Package Name

Available emulators and its package name is listed below.

Emulator/Project Package Name
RetroArch[N 1] org.libretro.RetroArch
RPCS3 net.rpcs3.RPCS3
DuckStation org.duckstation.DuckStation
m64p io.github.m64p.m64p
Yuzu org.yuzu_emu.yuzu
melonDS net.kuribo64.melonDS
Dolphin org.DolphinEmu.dolphin-emu
DOSBox com.dosbox.DOSBox
FS-UAE net.fsuae.FS-UAE
mGBA io.mgba.mGBA
Nestopia ca._0ldsk00l.Nestopia
PCSX2 net.pcsx2.PCSX2
Citra flatpak.citra-emu.org
PPSSPP org.ppsspp.PPSSPP
Snes9x com.snes9x.Snes9x
VICE net.sf.VICE
FUSE net.sf.fuse_emulator
ScummVM org.scummvm.ScummVM
bsnes dev.bsnes.bsnes

Snappy[edit]

Snappy, also called 'snaps' or just 'snap', is a distro-agnostic application framework made by Canonical, the Ubuntu devs. Unlike other formats, it is a centralized system and has the official repository to download the packages from. List of all packages can be viewed from Snapcraft (Apps are listed by categories).

Snappy has the following emulators:

AppImage[edit]

AppImage is a package format that allows software distribution without a superuser permission. Unlike the other two, AppImage does not have a system to find, download, install and uninstall the packages. Instead, it works like Microsoft Windows .exe files with no DLL requirements. The user must give the 'executable' permission to the AppImage package (chmod +x ./appname.AppImage) but this is the only requirement.

Unfortunately, emulator adaption is quite poor compared to the other two systems. RPCS3 and yuzu are the most notable emulators to officially adopt this format.

List of AppImage packages can be found in AppImageHub.

Emulators available in AppImage:

Emulators on Linux distribution[edit]

THE GNU/LINUX GUIDE OF EMULATION: Ubuntu edition[edit]

Important! Like the title says, this guide covers Ubuntu and its derivatives. While you may have lesser or equal success with distributions that use APT (Ubuntu's packaging tool), where there could be relevant information in your case, this guide is not to be used for distributions that use Pacman or YUM. We can't guarantee that repositories here will work with Debian and Ubuntu-based Puppy (like Tahr), but we're not saying it's not possible. Give it a try, and it could work if you know what you're doing. However, distributions like Arch and Fedora use completely different packaging tools, and thus are obviously guaranteed not to work. Don't give up, though; you can find the same emulators for your distribution somewhere else, either in their official or user-curated repos or by compiling them from source.

Info for new friends[edit]

Possibly the biggest difference between Windows and Ubuntu (and perhaps, GNU/Linux in general) is the way that programs are handled. On Windows, getting software requires the developer to package an installer (or a portable build for flash drives and the like) that you have to get from their website. They may also have to bundle dependencies (like the Visual C++ Runtime) or link you to their location if a license prevents that. If your software is closer to open-source, this is very different; either they have a repository that holds their own packages, someone has set one up for them, or they integrate their packages in the defaults (although this is very rare).

These "repositories" can be thought of like app stores. You use a package manager (either graphically or terminally) to search for programs in the repositories, from which you can install, update and uninstall them. It's really cool.

Your Linux distribution comes with repositories already configured so you can get a lot of the main programs immediately, but there are risks with the emulators in particular; repositories aren't focused on having every emulator, and in many cases when they do, they don't have newer versions. This isn't necessarily their fault though; especially with bigger distributions, repositories can be stuffed with loads of software that gets constant updates, so to get them tested and updated takes quite a bit of time. Rather than using the defaults, we'll add more repositories made by users or developers themselves that contain the latest versions of these emulators. Once these repositories are added, you will be able to install the emulators like with any other program and update them with the rest of your machine.

While this can seem exciting, keep in mind that some emulators aren't available on repositories, and many good ones aren't on Linux at all, so you may need to use different methods to get them. But don't worry; this will be explained later.

Adding new repositories[edit]

Note: If you ever rely on a tutorial that says to type apt-get, you can use apt instead. There generally isn't a difference.
Another note: Pay attention to where sudo is used. That's the equivalent to running a Windows program as an administrator. If you're ever suspicious about any command you're told to type, you can type man (command) short for manual and it will tell you what that program does. E.g. man apt will tell you what apt does. To quit the documentation, just press q.

Terminal[edit]

To add a new repository from the terminal, just type in this command:

sudo add-apt-repository ppa:user/ppa-name

...where the ppa:user/ppa-name are the ones you'll find in the table for the repository you want to add. After you add all the repos you want, you'll run the next command to tell apt to refresh the list:

sudo apt update

Once that's done you will have all the packages from those repos available to install.

Graphical[edit]

To add a new repository from the GUI, install synaptic (or make sure it's installed) by typing in this command from the terminal:

sudo apt install synaptic

This program will be a lot of help. Once you have it installed you can choose to organize packages by source and see all the repos you already have available.

Select Settings > Repositories, and from the new window, select Other Software > Add...

deb http://ppa.launchpad.net/ppa:user/ppa-name/ubuntu xenial main

Where instead of xenial for 16.04, you type trusty for 14.04, bionic for 18.04, focal for 20.04, hirsute for 21.04, and impish for 21.10.

You can then see what emulators you have with each repos, and can now install the ones you want.

Repositories list[edit]

The "Type" column categorizes repositories by update frequency. Software in the Testing branches usually get updates as often as possible (even daily), while software in the Stable branches are only as recent as the versions are, and usually get updates between a few months. There are also several Abandoned PPAs which can be used only on older Ubuntu releases.

If the desired emulator isn't found here, you can find more repositories by searching around for "(emulator) launchpad ppa". Check that they have packages for your Ubuntu version (they usually go by the version's name), as some PPAs can be abandoned.

Emulator/Project ppa:user/ppa-name Type Latest Emulator Version Supported Ubuntu Versions ARM[N 1]
RetroArch
(libretro)
ppa:libretro/testing Testing 1.9.10 18.04,20.04,21.04,21.10[N 2]
ppa:libretro/stable Stable 1.9.10 18.04,20.04,21.04,21.10[N 2]
VBA-M ppa:sergio-br2/vbam-trunk Stable 2.0.1-r202107030448-c08bb6bd-22 16.04,18.04
PCSX2 ppa:gregory-hainaut/pcsx2.official.ppa Stable 1.4.0 14.04,15.04,15.10,16.04,16.10,17.04,18.04
ppa:pcsx2-team/pcsx2-daily Testing 1.7.0~git202109251832+202109252351 20.04,21.04,21.10
MAME ppa:c.falco/mame Stable 0.235 18.04,20.04,21.04
ppa:c.falco/alpha[N 3] Testing 0.235 21.10
Dolphin ppa:dolphin-emu/ppa Stable/Testing 5.0+git-r202109240858-753a1595bf-33 16.04,18.04 arm64
PCSX-Reloaded ppa:rebuntu16/pcsx-reloaded-svn+unofficial Abandoned 1.9.94+git2017.02.28-16.13-1~ppa 16.04,16.10,17.04[N 4]
PPSSPP ppa:xuzhen666/ppsspp Stable 1.11-1 18.04,20.04,20.10,21.04
ScummVM Official Site (.deb)[N 5] Stable 2.2.0 18,04,19.10,20.04[N 6]
higan ppa:hda-me/higan Abandoned 106 16.04[N 4]
FS-UAE ppa:fengestad/stable Stable 3.0.5 14.04,16.04,17.10,18.04,20.04,20.10[N 6]
ppa:fengestad/devel Testing 3.1.0 14.04,16.04,17.10,18.04
DeSmuME ppa:random-stuff/ppa Abandoned 0.9.11+r1~4 12.04,14.04,15.04,15.10,16.04[N 7][N 4]
Mupen64Plus Abandoned 2.5-7+r630~7 14.04,15.04,15.10,16.04[N 8]
PokeMini Abandoned 0.60-r8~4 14.04,15.04,15.10,16.04,16.10,17.04,17.10
Gambatte Abandoned 0.5.0-r577-b575~5 12.04,14.04,15.04,15.10,16.04,16.10,17.04,17.10
Snes9x Stable 1.54.1-r201805250105-98d3d27-3 17.10,18.04[N 9]
BlastEm ppa:samoilov-lex/retrogames[N 10] Stable 0.6.0 16.04,18.04,20.04
Citra Testing 1:0.1~git20210618-1~retrogames 20.04
Dolphin Testing 5.0.14344-1~retrogames 20.04
Hatari Stable 2.2.1 16.04,18.04
Mednafen Stable 1.27.1 20.04
melonDS Stable 0.9.2-2~retrogames 20.04
mGBA Stable 0.9.1-1~retrogames 20.04
PCem Stable 17 20.04
PCSX2 Stable 1.6.0 20.04
PCSX2 Unstable Testing 1.7.1~git20210618.044034-1~retrogames 20.04
reicast Stable 1:20.04-2~retrogames 20.04
Stella Stable 5.1.1 16.04,18.04
Snes9x Stable 1:1.60-2~retrogames 20.04
yuzu Testing 1:0.0.0~git20200819-1~retrogames 20.04
Vita3K Stable 0.1.0~git20180527.1-3~retrogames 18.04
puNES Stable 0.106-1~retrogames 20.04
Yabause Stable 0.9.15-1~retrogames 18.04
FCEUX
ZSNES
Other older emulators not listed
Official Ubuntu repos Varies[N 11] Varies Varies ~
  1. These repositories have packages compiled for ARM architectures, and could work with HP Hardfloat, odroid, Raspberry Pi 2, etc.
  2. 2.0 2.1 Core availability may vary between Ubuntu versions.
  3. Some MAME builds may also appear in ppa:c.falco/trashbin.
  4. 4.0 4.1 4.2 This package is in the official repository for Ubuntu 18.04 and newer.
  5. ScummVM's website provides raw Debian packages (.deb) which can be installed with tools like gdebi.
  6. 6.0 6.1 This package is in the official repository for Ubuntu 21.04 and newer.
  7. Packages for 16.10 and newer are listed but broken.
  8. This package is in the official repository for Ubuntu 16.10 and newer.
  9. Packages for 14.04 and 16.04 are listed but broken.
  10. This PPA contains unofficial builds of RetroArch, Dolphin, PPSSPP, PCSX2, FS-UAE and more, thus may cause conflict with other PPAs if you are on Ubuntu 18.04 or below. (This is less likely a problem on 20.04 or newer because other PPAs have abandoned support for newer Ubuntu versions.) After installing a desired emulator from this PPA, it is recommended to remove this PPA from the system's repository list by executing "sudo add-apt-repository --remove ppa:samoilov-lex/retrogames" in the command line.
  11. Only updated once per Ubuntu version.

Distro-independent packages on Ubuntu[edit]

Main article: Distro-agnostic emulator packages for Linux

There are also distribution-independent emulator packages in Snappy, Flatpak or AppImage formats which can be used instead of Ubuntu PPA. These packages are especially useful for users of Ubuntu 20.04 or newer because most PPAs are abandoned.

Snappy packages are currently the default method of installing software in Ubuntu, encouraged by Canonical - developers of Ubuntu. Installing snaps is very simple, just open Ubuntu Software app and find your desired emulator from there, confirming installation with your user (or root user) password. No additional configuration is required to install snaps.

THE GNU/LINUX GUIDE OF EMULATION: Fedora edition[edit]

From repositories[edit]

Fedora has a very strict software policy, allowing only free software emulators, which don't rely on copyrighted BIOS files to work. There's quite a few emulators and even RetroArch with some open source cores, but you won't find any non-commercial or closed-source emulators in there. However, more of them are hosted at RPMFusion's repositories. To install RPMFusion's software repositories, use the following command as root:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

The second RPM is where you get proper video drivers for older AMD cards. Install "akmod-catalyst" (current AMD cards use the official "AMDGPU" driver built into kernel, so everything should work OOTB). NVIDIA users should instead follow this guide. The following emulators can be found from the RPMFusion repositories (note that not all packages are fully up-to-date):

Console Emulator
NES Nestopia
SNES bsnes, Snes9x, ZSNES
Game Boy/Color/Advance VBA-M
Nintendo DS DeSmuME
GameCube and Wii Dolphin

Can't find your emulator in RPMfusion? Want an up to date version git version instead of dolphin stable? First, check Fedora's COPR repositories. For example, for Dolphin, https://copr.fedorainfracloud.org/coprs/victoroliveira/dolphin-emu-git/. Still can't find a precompiled version? We get to compile them ourselves!

Compiling emulators[edit]

This could be considered a generic guide for all GNU/Linux distributions, but we will be using Fedora as our base for this tutorial.

First, in order to successfully compile software, libraries are required. You can generally find a list of dependencies with the emulator's source, but often those are listed for Ubuntu. So instead, enjoy this blanket list of programs and libraries to install:

# Compiler Stuff

  #dnf install clang clang-analyzer cmake ecj gcc-c++ scons

# Assorted Libraries

  #dnf install libx86 nasm

# Development Headers

  #dnf install alsa-lib-devel bluez-libs-devel cppunit-devel curl-devel enet-devel flac-devel freealut-devel glew-devel glib-devel glibc-devel.x86_64 glibc-devel.i686 glibmm24-devel gtest-devel gtkglextmm-devel gtk+-devel hidapi-devel jack-audio-connection-kit-devel jansson-devel kernel-devel libao-devel libevdev-devel libglademm24-devel libogg-devel libtheora-devel libudev-devel libusb-devel libuuid-devel libv4l-devel libvorbis-devel lilv-devel lua-devel lzo-devel mbedtls-devel miniupnpc-devel openal-soft-devel portaudio-devel pulseaudio-libs-devel python-qt5-devel qjson-devel qt-devel qt5-qtbase-devel qt5-qtx11extras-devel qtwebkit-devel ruby-devel SDL* SFML-devel SOIL-devel soundtouch-devel speex-devel speexdsp-devel tinyxml-devel

The reference text for the above list can be found here.

If you want automated emulator compiling, a Mupen64Plus build/update/install package exists here, just run the script for the function you require.

It is highly recommended that you read the scripts/readmes before running these so you understand what is going on.

As for compiling the emulators themselves, you're better off looking at the emulator's website/forum for specific tutorials. Emulator developers like to use a lot of different environments, from basic Makefiles to CMake to SCons to who knows what. The library list above and the automated scripts should help you get started if you're entirely unfamiliar with compiling, though.

If you still want help, feel free to ask in Emulation General.

Links[edit]