PS3 Modding

From Emulation General Wiki
Jump to navigation Jump to search

First off, you must have a PS3 on system firmware 3.55 or lower, to mod it. If you are on a lower firmware, simply upgrade to 3.55. However, if you're on a higher firmware, you must downgrade using a hardware flasher. Below is table for what models are downgradable and what flashers can be used on those models:

PS3 Model # Downgradable Progskeet E3 Flasher Teensy++

CECH-A to CECH-G

Yes Yes No Yes
CECH-H to CECH-Q Yes Yes Yes Yes

CECH-2xxx

Yes Yes Yes Yes
CECH-25xx Check Yes Yes Yes
CECH-3xxx No No No No
CECH-4xxx No No No No

All fat models are downgradable. If you have a NAND model (CECH-A to CECH-G) use Teensy++ and if you have a NOR model (CECH-H to CECH-Q or any downgradable slim PS3) use E3 Flasher. For downgrading you should follow a tutorial: Using Teensy++/Progskeet or Using E3 Flasher

Once you are on FW 3.55 you'll have to enter Factory Service Mode, to do that either follow this (see Chapter 2, Part 1), or use one of these devices.

Tutorial on going from OFW 3.55 to CFW 3.55

Upgrading from CFW 3.55 to CFW 4.30

Emulation

RetroArch

RetroArch has a PS3 port with lots of working cores that should cover most of the usual suspects.

Official Sony Emulators

Main article: Official Sony Emulators → Emulators on Playstation 3

PS2

You can emulate PS2 games on any model of the PS3 using ps2_netemu (Sony's own software-based PS2 emulator, also known as the "PS2 Classics Emulator"), which was developed for playing the PS2 games sold on PSN. It was never meant to be used as a general-purpose emulator, which means you really shouldn't be expecting perfect compatibility with games it hasn't been specifically optimized for, but many titles are playable. Refer to the PSHomebrew's PS2 Classics compatibility list for per-game info.

Note that if you own an old backwards-compatible PS3 unit, and it for whatever reason hasn't broken yet, you'll rather want to be using ps2_emu - the emulator that's launched when you put a PS2 game disc into the console. Unlike ps2_netemu, this one utilizes the extra PS2 hardware integrated in your console and has much better compatibility. ps2_emu is only usable on COBRA firmwares, meaning custom firmwares that integrate the functionality that was previously only available for those who bought the DRM'd Cobra dongle. Refer to Wikipedia's PS3 backward compatibility list for per-game info.

PSP

PSP games also work on PS3 through an emulator created for playing "PS3 Minis" from PSN, but compatibility is very limited (less than that of PPSSPP). Refer to PSHomebrew's PSP on PS3 compatibility list for per-game info.

Other useful info

You can connect to PSN while on CFW, but there is a high risk that your PSN ID and Console ID will be banned. There is a way to unban a console. It requires someone else's Console ID and it can be banned too.